99 Jimmy TCCM

01-12-2011, 12:04 PM
Ok i just bought this truck (99 Jimmy 4 button 4x4) and the 4x4 didn't work the lights on the buttons didn't even light up so i replaced the tccm and tried it and the button lights came on the service 4x4 went out and seemed to be working not sure though but that only lasted about 2 or 3 mins then the button lights went back out and the service 4x4 came back on. But when you turn the truck on now the tccm clicks about 4 times is that normal and what should i look at next. could have i killed the new tccm allready?

01-12-2011, 11:40 PM
ok i just read a forum saying to pull the codes from it and they say to ground pin 13 on the data cable (obd2 port) so i went to do that and there is no wire or contact in pin 13 what am i doing wrong?

01-13-2011, 02:07 PM
In this image, your connector look like the bottom one. Check behind the connector, maybe the wire fell out.


01-13-2011, 02:10 PM
In your picture there is 7 terminals is that how many there should be cause i could only count 5 i think it was on mine i forget witch pins though would have to go look.

01-13-2011, 02:45 PM
ok i just went out and unbolted the plug to look behind it and there is only 5 wires behind it and they go to pins 1 6 8 9 16 there is no 5 or 13?

01-16-2011, 09:39 AM
ok i just hooked a scan tool up to it and it doesn't say there is anything wrong. no codes. any ideas?

01-16-2011, 12:38 PM
You need to use a scan tool capable of reading body codes. Engine and transmission DTC's start with "P", ABS DTC's start with "C", and body codes start with "U". The cheapie scan tools that the auto parts stores use only access "P" codes.

01-16-2011, 12:41 PM
Cool thats what i thought but wasn't sure. guess im screwed with having to just start replaceing parts till its fixed

01-16-2011, 12:43 PM
Might be worthwhile to pay a shop to retrieve the DTC's then post them here. We can help you with diagnosis.

Add your comment to this topic!