2.4 blowing black smoke


cr_rider
12-25-2010, 12:34 AM
hey i've got a 1990 dodge ram 50 which has the mitsubishi 2.4 fuel injected. I bought it and it seemed to me as if it was running rich. its smoking at start and heavily smoking if i dump the throttle. I replaced the plugs and wires, cleaned the cap and roter, changed O2 sensor, and cleaned the TPS. Still blowing black smoke and running ruff. Possibly mass air flow sensor? or ECU? has anyone had this problem with this engine? would appreciate the help.
Thanks Jesse

danielsatur
12-25-2010, 06:50 PM
How many miles are on this truck?

1) Do a compression test on each cylinder, if good it's probably bad valve stem seals.

cr_rider
12-26-2010, 02:27 PM
160,000 miles will do compression check today and will post results

cr_rider
12-27-2010, 12:54 AM
Alright i did the compression check and got 170 on all four cylinders,also none of them leak. The wires arnt new, and the plugs got black carbon on them and smells like fuel. The air cleaner doesnt close right and tps,throttle plate,and throttle body are filthy and it needs a new filter. No check engine light but it runs ruff and sputters and blows black carbon powder out of the exhaust. I'm thinking of taking out all the sensors and cleaning them and then ill sea foam the truck through the throttle body then ill change the cap, roter, wires, and plugs. What sensor would cause it to run rich??

danielsatur
12-30-2010, 01:50 PM
If smokin after tune up, it's probably bad valve stem seals.
Try going with a new PCV filter, or with an external PCV filter.
This might help prevent less oil being burned.

cr_rider
12-31-2010, 02:56 PM
its blowing BLACK smoke therefore its rich. if it was burning blue smoke and droping oil levels i would think valve seals or rings but it doenst burn oil its burning to much fuel. It gets like 12 MPG

Add your comment to this topic!