Our Community is 705,000 Strong. Join Us.


04 suburban HVAC hot one cold other


wardriver
11-28-2010, 05:22 PM
I have a 04 Suburban with Dual zone digital HVAC system.

Worked fine Tuesday, heater core replaced during that procedure battery cable pulled.

Upon completion passenger side HVAC works great, driver side blows hot only. It will cycle to defrost, floor and vent WHEN i push the button however all positions are hot.

I have read some about the problem occurring when the battery cable is disconnected.

I have pulled the hvac fuses several times and notta, I pulled the negative batt cable several times and notta.

The hvac module was replaced 90 days ago, I suspect it has to do with the bat cable being removed.

PLEASE help.

wardriver
11-30-2010, 08:02 PM
2004 Silverado 2500 HD LS with dual climate manual controls.

Hot air on driver side while ac on passenger.

GM Service manual: Re-calibrate the AC computer

Set AC controls to cold, Fan off.

Under the hood, pull fuse HVAC/ERAC for minimum 10 Seconds. Reinstall.

Start engine and do not touch any controls for 40 seconds while the computer calibrate the AC.

Then use your AC normally. IF the problem continue, replace the drivers side temp actuator GM part # 89018365. You can find them on ebay by searching the GM partnumber. This is over 50% cheaper than the dealer.

To replace the actuator: Take off the duct shroud ( 4 screws ) and the actuator is right above the hump in the floor, only 2 screws & pull down. You can feel the spindel or shaft that connets to to flapper that lets in the heated air, open and close manually with your finger tips an you can hear it open & close. Line that shaft to the opening in the actuator and reinstall the 2 screws.

Add your comment to this topic!