Our Community is 705,000 Strong. Join Us.


truck wont stay running


|WYG|SS
11-26-2010, 03:12 PM
my friends 89 k1500 he has the 5.0l and he took the engine out and got the heads looked at and replaced seals and oil pump cuase it was leaking oil. we got it back in and running and he had a vaccum line hooked up wrong cause he had no power so i fixed it and took it for a ride and it had power and so i had him take it for a ride and as we were driving i noticed lights on the dash were going on like the battery light and C/E light. then on his road back to the house it it just completly died so we got out and seen that the small red wire that ran from the
+ battery terminal to the firewall had shorted and completely burnt off the terminal so my friedn tried touching the terminal with it, it sparked. then we get it towed back to his house and take a look and seen that it melted on the exhaust manifold and shorted. now we ran a new wire and tried starting it and it would not run. it will only run when yyou have your foot on the gas and once you let off it will run on what every gas and then die? what would be wrong?

j cAT
11-26-2010, 03:41 PM
my friends 89 k1500 he has the 5.0l and he took the engine out and got the heads looked at and replaced seals and oil pump cuase it was leaking oil. we got it back in and running and he had a vaccum line hooked up wrong cause he had no power so i fixed it and took it for a ride and it had power and so i had him take it for a ride and as we were driving i noticed lights on the dash were going on like the battery light and C/E light. then on his road back to the house it it just completly died so we got out and seen that the small red wire that ran from the
+ battery terminal to the firewall had shorted and completely burnt off the terminal so my friedn tried touching the terminal with it, it sparked. then we get it towed back to his house and take a look and seen that it melted on the exhaust manifold and shorted. now we ran a new wire and tried starting it and it would not run. it will only run when yyou have your foot on the gas and once you let off it will run on what every gas and then die? what would be wrong?


It is possible the computer got damaged from the arcing.
make sure all wires are securely connected. the grounds are clean and tight.. wires not melted together etc.

wire may have damaged a vacuum line ..

many a vehicle computer has been destroyed by arcing/poor grounds.

|WYG|SS
11-26-2010, 04:26 PM
yeah all the vaccum lines look go so maybe it could be the computer. i told him with the arcing that it could have damaged a lot of stuff or something major.

|WYG|SS
11-27-2010, 01:15 AM
well my freinds neighbor worked as a CAT mechanic for years and came over to take a look and he said he thinks they could have wrecked the computer. but before he could look at anything they turned the key right a way and it started right up and ran. maybe the computer just needed to be reset

j cAT
11-27-2010, 11:06 AM
well my freinds neighbor worked as a CAT mechanic for years and came over to take a look and he said he thinks they could have wrecked the computer. but before he could look at anything they turned the key right a way and it started right up and ran. maybe the computer just needed to be reset

with the voltage issues the computer may have needed a relearn to correctly adjust the engine controls.. good luck .

Add your comment to this topic!