Our Community is 705,000 Strong. Join Us.


car starts but turns off after 5-10 min


rjimenez2010
11-16-2010, 12:05 PM
My car starts up and it runs for about 5-10 min and then shuts off. then it will not start again while it is hot, if i leave it sit overnight then it will start again but the same problem will occur. the engine also has a misfire from the moment i start it up, can anyone help diagnose this problem. And after you diagnose it can you tell me ways i can check the problems. for example if you say its the fuel pump tell me how to check to see if my pump is working.
Country: United States
Make: Toyota
Model: Celica GTS
Year: 2000
Engine: 2zzge

Already Tried:
Heres what ive done to my car recently:_i have new engine coils,new fuel filter,new spark plugs,new thermostat ,i got my fuel injectors cleaned,new mass airflow sensor,new water pump.

SCJake
11-18-2010, 12:36 PM
not too keen on your specific engine, but sounds like it might be the plugs. you said it has a misfire from the moment you start and your injectors have been cleaned. dont take it as gospel but id check plugs first

take out the plugs. leave thewires attached though. cover up the hole (if you dont you couild blow yourself up) then keep the plug away from any metal while someone else turns the key. you should be able to see the spark. red = ok, but weak. blue= great. if red just clean it a little and if nothing changes you should be ok still. do this for each plug

again remember to fill the hole where the plug is. you can get vapors surrounding you and when the spark goes off you can blow yourself up. if you dont believe me just ask my right eyebrow... o wait... you cant

rjimenez2010
11-18-2010, 03:04 PM
car has great spark in all 4 cylinders.

Scrapper
11-18-2010, 03:18 PM
car has great spark in all 4 cylinders. is the spark blue or yellow?

SCJake
11-18-2010, 04:55 PM
the next place i would look is kinda hard to explain over forums. you need to see if it sounds like the engine is starving of gas or choking out. if it's starving out of gas then start with the fuel lines. easiest to check would be fuel filter. next would be to drain the entire system of fuel. then turn the key on but dont start the engine. sit it for 3 or so seconds, then turn it off. do this 4 or 5 times so that the pump can get the fuel back to the engine. if this doesnt work see if you can get a mechanic that does house calls (unless you have one???) and get that cool guage that hooks right up to the fuel rail and see if your pressure is low. low pressure will result in vapor lock. this is a very uncommon problem but you never know. i had it

SCJake
11-18-2010, 04:56 PM
too late but realized that was kinda vague. vapor lock is when the gas turns into a vapor before it gets to the engine. the injectors wont be able to inject it into the engine which basically starvs your engine.

rjimenez2010
11-22-2010, 05:39 PM
ok spark is blue....i just tried to replace the fuel pump because toyota master tech told me that it was a fuel problem and after checking the injectors by using a tester light he said it was the pump. i just replaced the pump and its the same problem. its gotta be the injectors right?

SCJake
11-23-2010, 08:38 AM
could be injectors. try a new fuel pressure regulator first. i had that problem and that fixed it. regulator ~$60 injectors anywhere from 250-1500 depending on model/how many/work done

SCJake
11-24-2010, 09:14 AM
i just thought of something. after it turns off are you able to start it back up right away or do you have to let it sit a while?

rjimenez2010
01-11-2011, 10:22 AM
i just thought of something. after it turns off are you able to start it back up right away or do you have to let it sit a while?

i have to let it sit for a long time

rjimenez2010
01-11-2011, 10:24 AM
too late but realized that was kinda vague. vapor lock is when the gas turns into a vapor before it gets to the engine. the injectors wont be able to inject it into the engine which basically starvs your engine.

fuel pressure test came out good

missamor
12-28-2011, 07:13 AM
Maby there is fuel filter jammed i changen and problem were solved

Add your comment to this topic!