Just picked up my first Rodeo, No Reverse?


JephyLube
11-11-2010, 11:28 PM
Hi i have been reading around and found out basically these transmissions suck.. I just recently bought a 1996 Isuzu Rodeo 2wd version and everything works great except there is no reverse? i work at jiffylube so at work i flushed my transmission out and changed the filter and also changed the external inline trans filter, still no reverse? could it be a bad switch on the tranny or? i have no check engine light and no check trans light, when i put it in reverse the rpms go to 2k all by itself then if i put it in neutral or park it goes back down to 1krpms?? any help would be great thanks

Cat Fuzz
11-12-2010, 01:35 AM
I'm no trans expert but from what I understand, if you have all forward gears but no reverse, it can't be clutch packs. I would start by dropping the pan and inspecting the valve body. I have a nice detailed .pdf for the 4L30E I'll send you. Just pm me your email.

JephyLube
11-12-2010, 01:49 AM
Alright ill check that my email is jephry253@gmail.com thanks

JephyLube
11-15-2010, 08:29 PM
Well i now have new problems, its having trouble going into 3rd gear it feels like if you were to drive a stick and shift to 3rd without using the clutch, and the check trans light flashes after that, the only way i can drive around now is to use winter mode and start in 3rd which is eating the trans up im sure, so im guessing the transmission is toast?

Anyone have a DIY or write up on how to change out the transmission on the 2wd vesrion? im very mechanically inclined so im sure it wont be a problem but there might be some important things i need to do to change it out.

Any help would be great thanks..

Add your comment to this topic!