2000 Impala SHUTS OFF while Driving....


mamaroo1299
10-28-2010, 09:54 AM
OMG...this car is a death trap when it decides to work....most of the time the car just doesn't start and when it does Oh Boy, Watch Out!!!!! from the gas gauge not working to the blinkers going INSANE to the Car just shutting off while driving 50mph on a busy highway....The other day as i was driving about 50 mph my car just STOPPED...Dead stop! No steering and as i watched a car in my rear vies mirror almost HIT me, I broke down and had enough..this has happened a few other times, but never on a busy road....I will NOT drive this car ever again....I called the Better business Bureau and they had chevy contact me..Well Chevy Sucks...Told me ** Oh Well, there is no warranty on the car and we haven't gotten many complaints about this problem so you have to have it fixed and pay for it** So I not so nicely told the guy to kiss my butt and said it will now become my mission since i am not driving the scary car to make sure that EVERYBODY who has this problem contacts the BBB.....Are they waiting for someone to get killed??????
Here is the BBB website...SEND IN COMPLAINTS!!!!!

maxwedge
10-28-2010, 01:03 PM
A 10 year old car, so get it fixed, what is the big issue?

SierraK1500
10-28-2010, 02:56 PM
Sounds to me you have a flaky BCM......have it looked at. While you are at the dealer have them check for error messages.

And yes I agree with Maxwedge.......get it fixed whats the big deal? And i am adding stop stressing yourself out and if you got hit in the rear its the other driver's fault. Your car "broke down"

John

:screwy:

demetrius316
10-31-2010, 09:50 AM
My car was doing the same thing.Then it died and would not start.The starter would not engage.Til i found out that I had a bad ground on the engine harness.I didn't have that problem til the shop replace my motor with a used one.Check the ground on the harness that mount to the motor.Right next to to starter it should be two wires.

SierraK1500
11-04-2010, 12:05 PM
My car was doing the same thing.Then it died and would not start.The starter would not engage.Til i found out that I had a bad ground on the engine harness.I didn't have that problem til the shop replace my motor with a used one.Check the ground on the harness that mount to the motor.Right next to to starter it should be two wires.

Thats an isolated case. I do suspect the BCM is bad and/or needs to be reprogrammed.

zoemayne
11-06-2010, 01:27 PM
my 00 impala would die on me while on the road(and start right back up put it in neutral while moving) it turned out to be the MAF sensor. but you sound like you have BCM probs I dont know if that would cause cut offs.

SierraK1500
11-15-2010, 11:53 PM
my 00 impala would die on me while on the road(and start right back up put it in neutral while moving) it turned out to be the MAF sensor. but you sound like you have BCM probs I dont know if that would cause cut offs.

I agree AGAIN...the BCM has got a bad case of the disentary and needs a new one. You can get a known good one at the junk yard and swap the BCM out. You will have to train the BCM to your car for it to start.

Connect the battery.
Try to start the car
Your dash may go out and you will see the security light.
Turn the key OFF and REMOVE it from the ignition.
Put the key back in and LEAVE the IGNITION on for 30 minutes.
Failure to leave the ignition on will result in another 30 minute reprogram
period. :nono:

Now shut the IGNITION OFF. REMOVE the key and re-insert in the ignition.
START the car normally.:cheers:


Now don't be a dummy and take your car out to a main drag.....Go on the back road and have SOMEONE FOLLOW YOU..... just in case your Impala dies.

If it does then get it to the dealer and have them read the error codes. If not you will be doing this...... :jerking: Have a good one and let us know what happened !!!

Add your comment to this topic!