2000 Lincoln LS v-6 suddenly died- no power


Mbsav
10-14-2010, 08:08 PM
I have had this car 10 years. It has served me quite well, to the tune of 280K miles.
Today I pulled out of a parking lot and the engine died and when I coasted to a stop I realized I had no electrical power at all. Nothing works. Dead as a proverbial doorknob.
What could be the culprit?
Is it a fuse or some sort of breaker?

I would appreciate any suggestions.

thanks

shorod
10-14-2010, 09:56 PM
Welcome to the forum!

Have you checked the battery in the spare tire well, cables, and fuses there?

-Rod

Mbsav
10-14-2010, 10:07 PM
Welcome to the forum!

Have you checked the battery in the spare tire well, cables, and fuses there?

-Rod

Hey, thanks Shorod. Looks like you have quite the following :0
I did check the battery- its less than a year old.
I will check the fuses in that rear power distribution box tomorrow.
it seems to me like it's going to be something simple like that. the way it happened was very quick.

By the way, I had a 94 Taurus SHO -I LOVED that car. It truly was a wolf in sheep's clothing. hated to part with it...

Mbsav
10-15-2010, 10:13 AM
Hey, thanks Shorod. Looks like you have quite the following :0
I did check the battery- its less than a year old.
I will check the fuses in that rear power distribution box tomorrow.
it seems to me like it's going to be something simple like that. the way it happened was very quick.

By the way, I had a 94 Taurus SHO -I LOVED that car. It truly was a wolf in sheep's clothing. hated to part with it...


Well, the battery was fine, but the connection to the power box had come loose. it was a very quick fix !!!

shorod
10-15-2010, 11:58 PM
Glad to hear you got it squared away, and thank you for following up with what you found to be the issue!

I'm on my third SHO now, I really do like them.

-Rod

Mbsav
10-16-2010, 03:58 PM
Glad to hear you got it squared away, and thank you for following up with what you found to be the issue!

I'm on my third SHO now, I really do like them.

-Rod

I am thinking about the new SHO- looks like you have one.

I'd be interested to know your good bad and ugly comments regarding this car....

Thanks again!

shorod
10-16-2010, 11:40 PM
I sent you a Private Message with comments about the SHO so far.

-Rod

Add your comment to this topic!