2000 rodeo trans question.


Gagecase
10-04-2010, 08:16 AM
My 2000 rodeo 2wheel drive auto has been rebuilt twice. When driving on the highway the check trans light comes on. also both times my tranny was rebuilt the solenoids seems to have trouble shifting between 1-2 gears. After awhile of this another light comes and the truck won't go anymore.

Gagecase
10-04-2010, 08:22 AM
forgot to ad the check engine light is flashing and gas light also flashing. My mechanic said egr valve needs changed and needs something for the gas gauge.

drove this morning was shifting bad in second gear(drove about 20-30 mins). Drove about 3 hours later with no problems, but only went a couple miles.

amigo-2k
10-04-2010, 12:22 PM
You would need the codes to know if the the EGR is plugged up . 98% of the time if it is an EGR code the EGR just needs to be cleaned (along with the EGR tube, which exits by the throttle body, see the FAQ's).

If your gas gauge is way off it is the fuel sending unit sensor. it is a 40 dollar part on the fuel pump ( you have to drop the fuel tank).

Transmissions on Isuzu will do funny things with weak electrical systems. How old is the battery? Have you ever replaced the alt? If so was it an aftermarket one or a Bosch one from isuzu. you can picked up used OEM alts on ebay for 50 bucks (I have one in a box waiting for the day my truck needs it).

It could also be a bad range mode sensor that bolts up to the side of the tranny. do the tranny indicators on the dash (PRND321) line up with what gear your truck is in? (I recently had mine replaced, because it was banging into and out of gears; 3 hours after this I started it and drove it to the dealer and it was fine, but I still had them replace the range mode sensor and all has been well for 2 months). Again details are available in the FAQs.

Gagecase
10-04-2010, 03:26 PM
You would need the codes to know if the the EGR is plugged up . 98% of the time if it is an EGR code the EGR just needs to be cleaned (along with the EGR tube, which exits by the throttle body, see the FAQ's).

If your gas gauge is way off it is the fuel sending unit sensor. it is a 40 dollar part on the fuel pump ( you have to drop the fuel tank).

Transmissions on Isuzu will do funny things with weak electrical systems. How old is the battery? Have you ever replaced the alt? If so was it an aftermarket one or a Bosch one from isuzu. you can picked up used OEM alts on ebay for 50 bucks (I have one in a box waiting for the day my truck needs it).

It could also be a bad range mode sensor that bolts up to the side of the tranny. do the tranny indicators on the dash (PRND321) line up with what gear your truck is in? (I recently had mine replaced, because it was banging into and out of gears; 3 hours after this I started it and drove it to the dealer and it was fine, but I still had them replace the range mode sensor and all has been well for 2 months). Again details are available in the FAQs.

Thanks for the reply. I had that range mode sensor replaced already so everything lines up now. I bought the truck used. I have never changed the alt or battery. I had to jump the battery a couple times last winter though. also when i roll up my windows the lights dim in the truck and on the outside car lights.

amigo-2k
10-04-2010, 06:11 PM
If the lights dim when you roll the windows up and down you have a load issue.

If you have 120k on the alt it probably won't hurt to find a lower mileage one on Ebay and swap it out. If your battery is 5 yrs or older I would swap that out too (if you don't know the history i would swap it out).

I would probably start with the battery. Also make sure the connections on the battery are good and clean, also make sure the ground connections on the battery are clean too.

Gagecase
10-06-2010, 01:45 PM
If the lights dim when you roll the windows up and down you have a load issue.

If you have 120k on the alt it probably won't hurt to find a lower mileage one on Ebay and swap it out. If your battery is 5 yrs or older I would swap that out too (if you don't know the history i would swap it out).

I would probably start with the battery. Also make sure the connections on the battery are good and clean, also make sure the ground connections on the battery are clean too.


Thanks

Gagecase
10-07-2010, 10:25 PM
truck ran good until I left school tonite. I had the lights and cd player going and then it happened truck started jumping in second gear. The check trans light came on as usual. The A solenoid im guessing. Gonna take to auto zone in the morning to clear light and check battery and alternator. Anyone have this happened?

Also the cig lighter doesnt work im guessing a fuse.

amigo-2k
10-08-2010, 12:01 AM
cig lighter ... could be the fuse or you may of used something with too high of a wattage and melted the wires and is causing an electrical issues.

Gagecase
10-15-2010, 07:28 PM
Auto zone checked battery and said it was good and also said alternator was good if battery was good. The check trans light only comes on when i drive for awhile I figured it tonite. Its a automatic and jumps from first to second gear. Like a knock sound sound when It shifts and jumps at the same time. Could this be in the wiring? the code says A solenoid. I said that already. Thanks fellas

P.S If I unplug my battery will that automatically reset the code to make check trans light go off? Sometimes it goes off by itself.

Add your comment to this topic!