1993 1500 4X4 fuel problem help!!!!


spencergatlin
09-20-2010, 03:08 AM
Sorry but this is going to be a little long winded so you know what I have done.
I replaced motor it's a 5.7 TBI motor ran great drove it for about hundred miles then had the trucks owner come pick it up.Next day calls me says fuel pump wont shut off so I find the wires to the oil sending unit are missing some insulation on wire so I tape it up and fixed.A week later calls me says if you gave it more than 1/4 throttle it would fall on its face.Checked fuel pressure was good but figured ok since the fuel pump staying on problem I changed pump and new filter ..Still give it more throttle than idle and it dies shot some carb cleaner with throttle opened up and it reved up great so I start replacing every sensor TPS O2 EGR the MAP the throttle body and distributor out of my running truck I even borrowed a computer out of identical truck there are no codes when I scan it .I cut exhaust in front of cat thinking maybe clogged mostly a frustration move on my part .
Heres my question I know the o2 tps map tell comp how much the injectors open Anyone have a trick to finding out where my problem lies I am writing this out of frustration before I break down and send to the dealer
As I said it starts idles give it fuel it dies starving for fuel
Made sure all grounds hooked up from body to engine etc.

Airjer_
09-20-2010, 11:44 AM
Are you sure the injector(s) are not bad. Have you ohm checked them?

bigj-dog
09-20-2010, 10:43 PM
Try watching the actual fuel spraying out of the injectors as the throttle is opened. See if it's drippy or if the spray changes much. I know you put in a new fuel pump, and checked pressure, but I chased a similar problem around in an '89, and ended up needing a delphi fuel pump instead of the off-brand I first bought. You might also want to try rebuilding the throttle body, the kit is only about 20 bucks, and it comes with a new regulator.

Add your comment to this topic!