96' missfire 2-3 cylinder

07-15-2010, 06:01 PM
My car is acting very strange and I am stumped as to what is causing this issue. A couple days ago it was acting up and hesitating...check engine light was blinking..seemed like possible feul pump issue so I i did the normal check and it was okay. the I took it to A Z and had them to a diagnosis. They told me #2 and #3 cylinders were missfiring and I had a bad o2 sensor. I took the car home and unhooked SP wire from #2 cylinder out put a spare on it and I got no spark then I did #3 with same result...I checked #1 and #4 and got a spark. Then I checked wires pulling #2 and #3 and interchanging them with #1 and #4 I got a spark so this pretty much told me the wires were good and something was bad with coil. I got a used coil from local salvage yard,installed it, and everything ran great so i pulled it out of my garge and thought" that was it no big deal" well when i drove it today it was good up until I stopped at store and then got back in it and drove off....then after about 1/10 of a mile it acted up same as before with no power and hesitation constantly. It also seems like it jerks or slips when I drive down the road.
Also Forgot to mention when this happens the car has a terrible feul/exhaust smell to the point that it is undrivable and makes me sick to my stomache.

07-15-2010, 07:40 PM
There are three possible causes. The coil you bought may be bad like the one you took off. Sometimes wires will cause the coil to go bad. I don't know where the coil is positioned on this particular model but before you change it check and make sure the ground is good. I have a 99 Escort and I have had issues with the coil grounding properly and it causes issues like you say are happening to yours. The second issue is that the bad O2 sensor is putting too much fuel into the cat causing the bad odor. Finally, check the exhaust for free flow as a blocked exhaust or cat can cause issues.

07-15-2010, 08:09 PM
I did gut the cat before thinking it was causing another issue and never replaced it. I hope this is what it is. I had that CAT on this way for over 6 months with no issue.

07-15-2010, 08:15 PM
I added some videos to youtube of engine running and sounds it is making.

07-16-2010, 01:25 PM
I pulled code P0135 O2 Sensor Heter Circuit Malfunction Bank 1 Sensor 1.
Does this mean O2 sensor above CAT closest to Exhaust Manifold is bad?

07-16-2010, 07:51 PM
Bank 1 Sensor 1 is the one in front of the cat not after it.

07-16-2010, 09:11 PM
I pulled code P0135 O2 Sensor Heter Circuit Malfunction Bank 1 Sensor 1.
Does this mean O2 sensor above CAT closest to Exhaust Manifold is bad?


07-19-2010, 09:02 AM
How many miles are on the car?

07-19-2010, 01:49 PM
Had similar issue replaced maf, idle control, egrand & sensor, 2 injectors, o2 sensor, fuel filter and fuel pressure regulator per codes none of these fixed it, it made it better. Idecided to go old school and checked each spark plug wire one at a time fond when i moved #3 just a little caused a miss wire it was bad wire 3 months old go figure.:frown:

Add your comment to this topic!