98 Frontier 4 cyl 4wd Dash Cluster


gbsocket
07-11-2010, 10:41 AM
Hey

Nothing in the dash cluster is working...heat & gas gauges are maxed out, speed sits around 20-25 km & tack around 1. Odometer reading is all 9's. I 've had it out cleaned it off, checked the fuses, even put in a new speed sensor & ignition switch, but nothing has worked. Nissan says they don't manufacture dash clusters anymore, so any suggestions as to what to try next???

TRU2AU
09-10-2010, 05:49 PM
Hello I am not sure if you have got your problem fixed. But if you need any guidance. I can tell you what you need to do. Please feel free to contact me if you need any help. My phone number 205-476-7972. Thanks and have a Blessed Day! Chris

gbsocket
09-17-2010, 12:15 PM
Hey Chris,

Haven't gotten the dash fixed yet, if you can give me any advice as to where to begin, that would be great! It's probably easier to post any advice...I'm usually on-line a few times during the day.
Thanks in advance

GB

MellowMike
02-20-2012, 10:28 AM
I test drove the same vehicle (98' Frontier 4wd) last week and it had the same problems. I've also had the same problem trying to find a fix. I'd like to get some more info or help before I purchase it. Get your's worked out yet? Anybody else know what the issue is?

ayew
08-22-2012, 09:05 AM
nothing worked on my old cluster so i found one on a vehicle that was wrecked and was working when it was wrecked, when i put it in my truck the odomenter read all nines and none of the gauges worked. I changed the alternator to a one wire alternator high output and we have not had any other problems with charging system. That way it doesnt have to go through instrument cluster. but i cant figure out how to reset the 9999 code on the speedomater I think that makes all the other gauges work.

Add your comment to this topic!