It just clicks-98 rodeo


kemolewis
06-20-2010, 06:48 PM
Hi all. I have a 98 rodeo, V6, manual. It won't start. It just clicks once then is won't do anything. I replaced the starter, checked the starter relay, had the battery tested, and replaced the battery cable terminals, not the actual cables. Still have the same problem. Sometimes the dash lights come on other times they don't. Just need an idea on where to go from here.

Thanks

Cat Fuzz
06-20-2010, 09:50 PM
Sounds like your replacement starter is also bad. The click is the solenoid plunger being pulled down but not making a connection. Don't let them bench test it and tell you it's good. The bench testers have more power available than a standard car battery and will make a bad starter appear good.

kemolewis
06-20-2010, 11:07 PM
Thanks for the reply. I thought the same thing so I took the starter back and got another one. Still got the same problem going on. Could this be an ignition issue?

toivo
06-20-2010, 11:14 PM
check your ground connection. make sure your ground wire doesn't hae green crud where the ends are crimped on and clean your block where your ground wire connects. also make sure your wire that operates the solenoid is not broken. toivo

Cat Fuzz
06-21-2010, 12:23 AM
It sounds like the solenoid wire is working. It seems to me that the starter isn't getting full battery power on the main lead. This is the big wire on the starter and connects directly to the positive battery terminal. I would check this wire out and also check all your grounds.

kemolewis
06-24-2010, 03:37 PM
Thanks for all the help. It ended up being the negative battery cable. Easy, cheap fix.

Add your comment to this topic!