starting trouble 02 impala


mickass
04-20-2010, 07:50 AM
Hi, I have some trouble with my 02 chevy impala. When the I turn off the engine of my car car he won't start back until he's got cold. When the car is cold he start without any problem but when he's hot and I turn it off he would'nt start again. I changed the crink sensor, the cooling temperature sensor and that change anything. I check the codes but the only one is about the catalyst but I don't have any system 'cause I took it off and I change it for a pipe. I went to a GM dealer and they don't found the trouble. What I can do and there is anyone who's knowing something abour that ???

maxwedge
04-20-2010, 04:48 PM
It won't start at all when hot?, till it cools down.

mickass
04-21-2010, 06:49 AM
yes, if the motor is hot like to quarter and up he won't start, if I try it I have to wait until he's got cold. Because when I try and the motor is hot it willn't run, it will just start ans start and start, it will be drew.

maxwedge
04-21-2010, 09:01 AM
Tough to tell what your are saying, good job based on the language issue though, check for raw fuel in the hose to the fuel pressure regulator. If ok, make sure you have spark to the plugs when this happens.

kevinb70
04-21-2010, 10:12 AM
when engine is hot, will it crank with LIGHT pressure on the accelerator pedal? this will pinpoint an issue with the IAC. this will open the "throttle butterfly" and let some air in, if idle passage is blocked or IAC is stuck/immovable.

when I was diagnosing my no-start recently, sometimes it seemed like "no spark" and sometimes "no fuel"..... but the real problem was "no air" !

do not guess and replace parts ... money is wasted.

mickass
04-21-2010, 12:41 PM
Ok,Thank ! I'll check for that cause it's begginning to do ******* me. I always go to chevy and it's beggining to cost me a lot and they seems a little bit mix.

mickass
05-06-2010, 11:28 AM
I still have problem with my impala I changed the IAC and the fuel pression regulator and that change anything I still with the same problem ! Do somebody can help me ???

ChevyCelebrity
02-26-2011, 12:45 PM
I have the same problem with my 2003 Chevy Impala 3.8. If the car is cold or hot, it will usually start up with no trouble. But the car has cooled down a little bit (like when I run errands) the car has trouble starting. When you try to start it up it will start, but it will usually stall out almost immediately. However if you press the accelerator while you start it, it usually doesn't stall because the engine revs while it struggles, which allows it to keep running. I cleaned the IAC and there are no trouble codes. Anyone?

maxwedge
02-27-2011, 05:44 PM
Try cleaning the the throttle body.

ChevyCelebrity
04-29-2011, 10:14 AM
I just finished replacing the fuel pressure regulator and so far so good. Thanks!

Add your comment to this topic!