98 Eclipse GS cranks, won't start


justknox
04-06-2010, 04:13 PM
Alright, I've been sitting on this car for awhile trying to sell as is (not running) and so far I'm getting low low ball offers. I wanna keep trying to get this thing running so I can get it out of my life.

Here's the deal. Replaced ECU, crank sensor, cam sensor, nocks sensor, fuel filter, spark plugs, ignition coil, ignition wires, battery is fine, not the starter, ASD relay is functioning, fuel relay is functioning.

Cranks, won't start (sometimes it will start but it dies shortly after) and I'm getting no spark at all. It just won't fire up. I have no clue what has happened.

Few months ago I replaced the clutch, drove it for about 520 miles and then as I was leaving my place it died in the road (just completely shut down, no warning at all, all the sudden I just couldnt accelerate).

Replaced the ECU and it started up again, died in the same manner on the freeway and had it towed to my place. That's when we started replacing every sensor we could think of and every stupid thing we could find. Looked up a lot about the piece of shit dodge engine, learned about the asd relay and nothing has worked.

If anyone has had similar problems (and I know there has been a lot of the same problems) then please get back to me whether you were able to fix it or not.

Hell, maybe the car is just dead. If you need more info ask

[EDIT] Also, ran computer on it and it green lights, no problems detected.

SilvrEclipse
04-06-2010, 09:03 PM
Welcome to AF.

They are a few things you can check to help narrow the problem down some. Do you have fuel at the rail? There is a test port on the passenger side with a schrader valve. Push that in and fuel should shoot out. Also check to see if the middle pin on the coil pack has 12v when cranking. Also check and see if the injectors have power when cracking.

Have you checked to see if the motor has jumped timing? Or done a compression check?

justknox
04-07-2010, 02:36 AM
Thanks for your response.

Yes, I have checked the fuel rail, and it spits out fuel. One of the things we tried earlier on. Timing was checked and turned out fine. I cannot remember whether or not we ran compression or not, haven't worked on it in a good month and a half (currently working on 91 300zx). I'll try and check volts @ coil in the morning as well as injectors. And I'll ask my roommate whether or not we ran compression and if not do that as well and get back to you.

[EDIT] Wasn't able to do compression today but did check coil, wasn't getting anything from the plug. Didn't check injectors but was told I wouldn't need to since I'm not getting anything from coil.

Add your comment to this topic!