96 Altima distributor is leaking oil everywhere


fritcr
04-06-2010, 02:53 PM
Is this common? For it to leak quite a bit of oil out? I bought a new distributor today but am unsure if I will need to retime the engine after I install it? If so do I need to unplug something to do so? And last but not least what should it be timed to?
Rob

jserrano
04-07-2010, 06:36 AM
Yes, you'll need to check and adjust the timing back to the stock 20 degrees.

fritcr
04-07-2010, 07:44 AM
Do you happen to know how to do that? (I know how but is there anything I need to disconnect before setting the time??) To keep it from advancing etc?

cancan
05-03-2010, 02:09 AM
93-96 should have the same firing order, what you need to do is put your engine's first cylinder in TDC. before you put the new or rebuild unit you need to align the red mark of your crankshaft pulley whit your pointer your cylinder must be in the TDC in the compression stroke not the exaust stroke. Take the first cylinder spark plug out to make sure your in the correct timming, put a metal long socket extencion on the hole to verify. Put car in neutral and rotate the crankshaft pulley bolt clockwise whit a socket and ratchet, put car back in park. Put alignment marks in old distributor and engine block before removing, transfer marks to new unit same place that you put in the old unit, take bolts out and pull old unit. line the male slot of the unit to the female slot in the engine block, push the new unit in align your alignment marks put and tighten bolts. Put everything back in it's place start car and check for timming whit a timming light

fritcr
05-03-2010, 08:45 AM
I got the distributor in but have not checked the timing. I will try to do that soon. It seems to run fine but now, after several days, it has and O2 sensor code. I put a new O2 sensor on it and a new cat late last year so I don't know why it would be showing a code again?? Any ideas.? I visually checked it and it looks fine and the wires are fine.
Also, suddenly about the same timeish...now the speedo seems to get stuck then if you tap the dash it will work? My daughter is 16 and don't have a job yet so I'm trying to keep it going for her! lol
Any advice greatly apprecated!
Rob

Add your comment to this topic!